Issues with Samsung One UI 6 / OS 14 Upgrade
  • 30 Mar 2024
  • 2 Minutes to read
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Issues with Samsung One UI 6 / OS 14 Upgrade

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Article Summary

Recently, we have observed an issue affecting Samsung Android devices that received an update to Samsung One UI 6 as a part of the upgrade to Android OS 14. The below article summarizes the issues and documents the workarounds or the resolutions.

Issues

  1. Certain applications (camera in specific) may not open and auto close the application.

  2. The home Key and back key may go missing or become non-functional.

  3. Adding attachments to third-party applications may not be functional.

Impacted devices

Potentially any device upgraded to Samsung One UI 6 and Android OS 14

Root Cause

The upgrade to One UI 6/OS 14 is revoking key permissions of Scalefusion set-up, the One UI set-up wizard is taking over Scalefusion launcher permissions which is thereby disrupting functionalities inside the Scalefusion Kiosk.

Mitigation Plan

  1. Prevent and block updates to One UI 6 and Android OS 14.

    1. Edit the impacted device profile(s) -- navigate to restrictions -- device management -- toggle off OTA updated.

  2. Postpone OS Update policy.

    1. Edit the impacted device profile(s) -- navigate to OS update settings-- update settings -- override global setting -- set to postpone.

Remedying Impacted devices

Approach 1: Completing the OneUI onboarding

  1. Update the Scalefusion Android Agent to 13.0.4-IC available on the dashboard under Application Management -- Scalefusion Apps.

  2. Complete Scalefusion set-up on the the impacted devices.

    1. Click on the three dots menu inside the kiosk and you should see the option to complete setup, following instructions to complete the setup, with a few clicks will resolve the problem, validate by clicking on the three dots menu again and you will now see that the option to ‘complete set up’ no longer appears.

    2. If the complete setup option does not show in the three dots menu, add the following packages to the device profile(s). Edit the impacted device profile(s) -- add the application.

      1. Enable com.sec.android.app.launcher package from the profile & enable the Allow lock task.

      2. Enable com.sec.android.app.SecSetupWizard & Allow Lock task from profile.

Approach 2: Switch to Agent mode

Switch devices to Agent mode instead of the pre-set Kiosk mode, if that is acceptable for usage and user experience. Edit the impacted device profile(s) -- set Scalefusion as Agent

Conclusion

The above steps and manual intervention are necessary due to Samsung’s OS-level changes, hence leaving us with no alternative solution at this point. 

We understand the inconvenience and frustration this may cause, and we apologize for any negative impact this has had on your operations. 

We are actively working to find a more feasible solution and we will keep you updated on any developments.


If you have any questions or looking for more information, please contact us at support@scalefusion.com


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